0

I am getting constant errors when importing a csv file into marketing cloud. It seems that no matter which date format I choose, the file still errors although most of the records go in, but not all. This is what MC notification says:

Results:

Inserted: 174838

ValidationErrors:

Invalid Date: 1825

This is the date format in the csv file:

2019-01-31

Example Records (I have removed sensitive info): This one failed: "3245123","251205123","xxxxxxxxxxxxx","2014","XXXX","Extended","Active","","MCCSO","12345678","me@me.com","My Company Co.","Suite 123","","","XXXXX","VI","00801","","","","","UP888","VIISI","2019-01-31","","","","","","","","","","","","","","","",""

This one was inserted: "71443123","20295433","XXXXXXXXXXX","2019","XXXXX","iiwjjwiiiiiw","Active","ME","ME","7268164","","My Services SERVICES INC.","162025 Main Road somewhere","","","SomeCity","GA","9399200","Somewhere else","LALA Land","LA","123232","BT56776","US","2020-02-29","","","","","","","","","","","","","Y","Status","2022-01-11",""

Can anyone recommend a format which should work with this?

Thanks

9
  • 1
    Since you have managed to insert 174838, then I suspect the date format being inconsistent in your file. Or is the date field only populated on 1825 records? Jan 12 at 19:15
  • Hi Lukas, the date format is consistent across all records and in the same format. Its strange that MC will import some but not all records
    – DavidB
    Jan 12 at 19:18
  • 1
    help.salesforce.com/s/…
    – EazyE
    Jan 12 at 19:19
  • Yes I have been there. Going by that doc Afrikaans (South Africa) would be a good fit. I have already tried that and get the same error.
    – DavidB
    Jan 12 at 19:27
  • fr_CA is normally my preferred date format for yyyy-mm-dd, with 24h time format. You might want to give it a try Jan 12 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.