-1

I m getting error invalid fullname, must end in a custom suffix ( for ex. __c ) when deploying changes via Github (2 custom fields on , one on lead another on the Opportunity )to another sandbox.

Also verified the field names and api names too , it showing correct. Can anyone help me on this.

enter image description here

2
  • 2
    Please provide us the definitions of those fields.
    – Damecek
    Jan 11 at 17:35
  • @Damecek LAbel : MDR Footprint API name:MDR_Footprint__c . Names are same in both Lead and Opportunity Jan 11 at 17:42
2

Errors of this nature occur when a specific feature is not enabled and you try to deploy the object/field that the specific feature exposes. Try enabling In-App Guidance in your org before deploying.

3
  • but i m not adding my fields any where in In-app Guidance and its not enabled in my Org @Sfdxfox Jan 12 at 7:51
  • @BRAHMAREDDY But it's in your metadata. If you're not using it, remove that object from your source code.
    – sfdcfox
    Jan 12 at 13:06
  • it worked for me thank you. After enalbeing the In app guidence it working as expected Jan 20 at 10:01
0

Try matching the licenses in the target sandbox with Production by doing: Setup > Company Information > Match Production Licenses prior to your deployment. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.