1

Set up

  • I have a profile for an external user called "Software manager".
  • "Software manager" has read access to account & contacts.
  • Organization wide default (OWD) setting for look up fields is set to "Require permission to view record names in look up fields"
  • The profile does not have "View all look up record names" permission.
  • The user has a customer community plus license.

Issue

  • If the user goes to the list view of contacts then the user can only see his own contact (not other contacts associated to the same account).
  • If the user goes to account - related records view, then the user can see his own contact name and all contact names associated to the account. However if he clicks another name then an error is given.

How can I prevent the user from seeing the other contact names in the related list view? I don't want to hide the related list view but only let him see his own name there.

Research

Another post mentioned that it might be the consequence of implicit sharing. This by reasoning that because he can read the account object (the parent) he can also read the contact objects (the children). However if this is the case, how come that the user cannot actually read the contact records? He can only see the names. On top of that it's not like the user is the owner of the account object, he's just a contact created under the account object. Which makes me wonder how he can even read his own account as External OWD for account is set to private, but that's another question.

Update: The issue is resolved when changing the external OWD sharing setting of contact to "Private". It originally was "controlled by parent" and the parent object being account (I assume?) set to "private". I don't know what's the difference between the two situations but the latter one gives a weird outcome. I'll accept any answer that can explain why salesforce acts this way for the second situation.

3
  • 1
    This seems related, although the circumstances are slightly different. Dec 30, 2021 at 15:14
  • Indeed, I just figured out that the issue is resolved if you change the Sharing settings from contact to "Private" for external users. This is weird in my opinion as the setting was "controlled by parent" and the parent (being the account I assume?) was set to private. So I don't know why it gives a different result.
    – ThaNoob
    Dec 30, 2021 at 15:29
  • I agree. This should at least be documented somewhere, e.g. here. Dec 30, 2021 at 18:25

0

You must log in to answer this question.

Browse other questions tagged .