Has anyone had an issue with checkpoints not showing in the "Checkpoints" section on the "Checkpoints" tab in the Developer Console? I've added a checkpoint in my apex trigger, the location of the checkpoint shows under the checkpoints tab, but not in the "Checkpoints" section. Not sure what I'm doing wrong.

enter image description here

4 Answers 4


I have observed that sometimes it takes more than 10 seconds to refresh but it worked correctly for me.

It may be performance degradation issue on your instance.

From the image your shared everything looks right from your side.

May be you can try waiting for longer time or raise a support ticket.

  • Actually, I've also been having a problem with checkpoints, but I'll try being patient.
    – sfdcfox
    May 21, 2014 at 15:37
  • Yeah there seems to be weird stuff going on in that area. See salesforce.stackexchange.com/questions/36585/…
    – BarCotter
    May 21, 2014 at 15:48
  • Been waiting most of the day. Still nothing :( Also tried a different browser.
    – Adam H.
    May 21, 2014 at 18:03

Setting the global APEX level to 'Finest' does not work, however setting the specific class trace overide to 'Finest' did the trick for me.

TIP: To avoid pulling your hair out - if the Developer Console doesn't do what you expect it open up the Chrome Developer Tools and see if there are any JS errors, if yes there is not much you can do about it except file a bug.

Set apex to 'Finest' in overrides section Working Checkpoint


Note this from the documentation


"To use checkpoints, the Apex Log Level must be set to Finer or Finest."


After reading here about looking for js errors, I switched from Safari to Chrome, and my checkpoints then appeared.

It seems that Chrome works better than Safari for developer console.

  • switching from safari to chrome also worked for me. would have upvoted or commented on @BoLaurent answer but don't have enough rep.
    – BoldAsLove
    Sep 6, 2017 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.