3

I'm attempting to create scratch orgs via GitLab pipeline which includes LiveAgent, Omni-channel and skills.

Looking at the Metadata Coverage report I can see that queueRoutingConfig is supported. And that the developer documentation for this requires Omni-Channel to be enabled

force-app/main/default/queueRoutingConfigs

My hunch is that sfdx isn't enabling Omni-Channel properly. Does anyone know why?

Project Scratch Def file

    {
    "orgName": "****",
    "edition": "Enterprise",
    "features": ["PersonAccounts","Communities", "Entitlements", "MultiCurrency", "LiveAgent", "SocialCustomerService", "ServiceCloud", "ServiceUser", "Knowledge", "SalesUser", "ForceComPlatform", "API"],
    "settings": {
        "orgPreferenceSettings": {
            "s1DesktopEnabled": true,
            "s1EncryptedStoragePref2": false
        },
        "knowledgeSettings":{
            "enableKnowledge": true
        },
        "nameSettings" :{
            "enableNameSuffix":false
        },
        "liveAgentSettings" : {
            "enableLiveAgent":true
        },
        "emailAdministrationSettings": {
            "enableEnhancedEmailEnabled": true
        },
        "omniChannelSettings": {
            "enableOmniChannel": true
        },
        "caseSettings": {
            "systemUserEmail": "support@acme.com"
        },
        "lightningExperienceSettings": {
            "enableS1DesktopEnabled": true
        },
        "communitiesSettings": {
            "enableNetworksEnabled": true
          },
        "quoteSettings" : {
            "enableQuote" : true
        }
    } 
}

1 Answer 1

0

The Metadata Coverage you provided also has a tab for sample scratch definition

{
  "orgName": "Sample Org",
  "edition": "developer",
  "settings": {
    "omniChannelSettings": {
      "enableOmniSkillsRouting": true,
      "enableOmniChannel": true
    }
  }
}

You'll notice you're missing enableOmniSkillsRouting within OmniChannelSettings which I presume is why you're running into that error.

Indicates whether skills-based routing is enabled in your org. The default value is false.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.