1

We are attempting to deploy some code into a production SalesForce instance. But deployement fail because already installed third party packages are failing the unit test requirements. We get the following error on all existing unit tests.

line -1, column -1: Previous load of class failed: pkb_Controller: line 1, column 24: Entity is not org-accessible

Can you please advice us on how to fix this? and whats causing this error?

3

We had the same issue and the root cause was that there were (3) Article Types enabled with the KB2 install and one, Error Message Article Type, was disabled. We were then using only (2) Article Types and the test case was written to address (3). Activating that unneeded type resolved the issue.

The test case just needs to be revised to provide a correct resolution.

|improve this answer|||||
1

Please check that the knowledge is enabled in your ORG also check that you are knowledge user if you are deploying the app in production.We have used the PKB and we experienced same issues .This request is for PKB application

And by looking into issue it may be due to the name change of the class in both the instance or the method has been renamed .Please check names of all class in both the instance and also try to run the test one by one to figure out which class has been renamed .

|improve this answer|||||
  • It sounds plausible, that if the package is dependent on Knowledge being enabled - if it is disabled or the running user does not have access, it is preventing the class from referencing Knowledge entities and hence failing. – techtrekker Oct 24 '12 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.