1

I am trying to implement a project with LWC OSS, when trying to import lightning-input I am facing the following error.

Lightning/ariaObserver @somyatiwari59

I tried to import the lightning-button and I was able to import the same successfully. Only issue is with the input which has an import as lightning/ariaObserver Lightning-button working fine @somyatiwari59

Here is the GitHub Code Link: """Removing Link due to some Reason."""

2 Answers 2

1

I was making a mockup over the weekend for another answer, and I ran in to this exact same bug. To work around it, I downgraded to [email protected]. Fow now, try changing your lwc.config.json file to:

{
    "modules": [
        {
            "dir": "src/client/modules"
        },
        {
            "npm": "[email protected]"
        },
        {
            "npm": "aws-sdk"
        }
    ]
}

I'm going to try and get a bug report filed for this.

1
  • Thanks, it worked, but it was a bit different from what you suggested. Posting the correct answer :) Dec 6, 2021 at 16:53
1

As suggested by @sfdcfox it was the version issue with lightning-base components. I installed the version 1.13.9-alpha, and it started working. Although the changes are as follows:

"dependencies": {
    "@lwc/synthetic-shadow": "^2.6.1",
    "aws-sdk": "^2.1043.0",
    "compression": "^1.7.4",
    "express": "^4.17.1",
    "helmet": "^4.6.0",
    "lightning-base-components": "^1.13.9-alpha",
    "node": "^16.13.1",
    "util": "^0.12.4"
},

in the package.json file. the lwc.config.json remains the same as follows:

{
    "modules": [
        {
            "dir": "src/client/modules"
        },
        {
            "npm": "lightning-base-components"
        },
        {
            "npm": "aws-sdk"
        }
    ]
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .