1

Hope you're well. I'm currently building out a report, but despite my best efforts so far, I can't get some information to populate within the report. It does not appear to me that salesforce is recognizing the field "Agent Incoming Connecting Time" within the object "AC_Agent_Performance". However, I can pull in some other fields within the same object into the Agent Performance report, so I'm not clear on what is not taking place in the field that I wish to see within the report. Here are some of the things that I've tried:

  1. I have checked the access to the field. The first photo (Photo 1) Shows an example of a working object, the the second one shows an example of one that does not.enter image description here enter image description here
  2. The API name seems to work, and is consistent with other fields within the object that work.
  3. I have checked the page layout for the object (even though I don't think this is the issue), and I have mirrored other fields to the best of my knowledge that ARE populating within the report.
  4. I reviewed the CTI flows to see if there was something missing in there on a lark, but there was nothing in there that would lead me to believe that this was the source of the problem.
  5. I have tried setting up a new field in the object (formula), that references the field that I'm trying. to pull in, but that just returns a result of 'zero' for all values.

One thing that I have done that appears to be working, is I have set up a joined report, which uses both "AC Agent Performance" object and "AC Historical Queue Metrics" object in the report. The result that is returning appears to be accurate (please see the picture (picture number 3)enter image description here). However, I don't think that this is the right way to go about this, and I don't want to do it this way. I want to use the report with one object rather than with two.

I know that permissions are the most likely issue, so I've taken a close look at these. Please let me know if there is something wrong with how I have the permissions configured. The First image depicts the 'Field Level Security'. The second image depicts the'field accessibility'. They are both like this, the whole way down:

enter image description here enter image description here

Please note one other thing, which is that the last picture depicts a different field within the object displaying in the report.

enter image description here

Does anyone have any ideas on how I can proceed so the field "Agent Incoming Connecting Time" will display within the report?

Please also note, that these are objects that contain data that is populated from AWS' Amazon Connect.

This last photo, shows that the object does not have any information in it within the report.

enter image description here

2
  • Welcome to Salesforce Stack Exchange (SFSE). Unfortunately I know very little of reports. Hopefully the answer @JimG gave will work, or - if not - he or someone else with knowledge in that area will still be able to help. I just wanted to thank you for such a well written question, and for including screen shots and everything that you've tried so far. That is refreshing for a first-time poster. Please stick around and keep contributing!
    – Moonpie
    Dec 4, 2021 at 22:58
  • Hi there, I could use a little help with this question if anyone has any thoughts.
    – Steve
    Dec 6, 2021 at 0:13

1 Answer 1

0

If you can see the field on the page layout, but not on the report builder's "all fields" drawer, it's likely an issue with a custom Report Type. Go to Setup > Quick Find > Report Types. Find the "AC Agent Performance" report type, edit layout, and drop all the fields on the layout. This will "enable" them for the report.

3
  • Hi Jim, I can see the field in the "All Fields" drawer (by which I assume you mean the drawer field on the left hand side of the page), but no data is populating the column within the report. Please see the last photo.
    – Steve
    Dec 5, 2021 at 0:19
  • Hi Jim, this does not work. Do you have any other thoughts?
    – Steve
    Dec 6, 2021 at 1:45
  • Ah. I misunderstood. I'd assumed the issue was that the field wasn't available to drop onto the report, which would have been a report type issue. But it soulds like you can drop the field onto a report, but the data values aren't showing. I'd assume this was a data issue. IE: do you have a record that definitely has this field filled in? If so, adjust filters on a sample report to zero in on that record and try to figure out why the other records have no data. Good luck!
    – JimG
    Dec 6, 2021 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.