2

I reset my password, and then my security token.

But my Mule connector won't connect, and "Force.com Explorer (Beta)" says Login failed: INVALID_LOGIN: Invalid username, password, security token; or user locked out.

I know that for Explorer it's password + token, I did that carefully. And carefully changed the connector's settings.

Things I've tried:

  • Logged out and logged back in to the main website with the new password.
  • Tried the Reset Security Token again
  • Waited a while (20 mins) after the email to give SF a chance to update its caches or whatever
  • Fully exited Explorer and went back in
  • The account isn't locked, I'm able to login
  • Tried not to test too many times in a row, so as to not lock the account
  • I'm typing the password carefully and pasting the token, no extra spaces, etc.

Is there some known issue with password or token resets? Some magic length of time?

2
  • Were you able to resolve the issue?
    – highfive
    May 17, 2014 at 7:04
  • @highfive yes, thanks for checking, so I posted the answer. May 18, 2014 at 23:25

2 Answers 2

2

If your token gets reset often you can also whitelist your IP by going to

Security Controls -> Session Managment and get your IP ->Then go to Network Access and Add your IP in there`

It gets annoying when your trying to manage your security keys with Force.com explorer, and a IDE esp it changes often..

This will also help you.

1

Turns out I was "off by one" in the emails they were sending me with new tokens, some type of delay, and I they sent one more than I expected, so I hadn't noticed the delay.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .