In our org, deactivation of Matching Rules and Duplicate Rules was required by the encryption process in order to encrypt a field (Contact Email). When we try to re-activate these rules, we are receiving the message below:



You tried to activate the matching rule Contact Match based Email for identifying duplicate records. However, we can't activate the rule because it defines an unusually large number of records as possible duplicates. Specifically, take a closer look at these fields:




Edit Contact Match based Email to include a field that contains more unique values, and then try activating the rule again.


Here's a simple example of a matching rule that's too broad. Let's say that you create a rule which determines whether accounts match by looking at the billing country. If you have 1,000 accounts based in the United States, this rule is going to flag all 1,000 U.S. accounts as duplicates of one another. But most of those accounts probably aren't actually duplicates.


Then let's say that you change your rule to add a field with relatively unique values, such as ZIP code or street address. The rule now produces more useful results, flagging fewer records as duplicates.


For more information, see Match Keys Used with Matching Rules in Salesforce Help.

Per Salesforce documentation, "In the Summer '17 release, Salesforce introduced a feature to prevent the activation of ineffective matching rules... Matching rule activation is blocked when the sum of all sets of 100+ identical match key values exceeds 2% of the number of total match keys."

I then executed the following SOQL:

SELECT Count(id), email, from contact GROUP BY Email  HAVING COUNT(Id) > 2 ORDER BY COUNT(Id)

And I get

Count(Id)     Email
5411           (blank)

But we do not have any duplicates in the Sandbox. Unless it is counting the blank as a dupe.

Are there any suggestions for resolving this issue? I know I can contact Salesforce to increase the 2% threshold but I wanted to understand the problem and why it is saying dupes when there are not.



You must log in to answer this question.

Browse other questions tagged .