0

I am trying to set up a MyTrailhead subdomain on a sandbox org as mentioned here:

https://help.salesforce.com/s/articleView?id=sf.mth_set_up_your_mth_subdomain_and_namespace.htm&type=5

My user is a system admin user that has a permission set assigned that gives the MyTrailhead licensing and permissions (all of them).

After visiting https://trailhead.salesforce.com/en/subdomain/login-required, I log in using the Salesforce login for my sandbox instance.

I am then sent to the following url : https://trailblazer.me/AuthProviderError?ErrorCode=No_Oauth_Token&ErrorDescription=invalid_grant+authentication+failure&ProviderId=SomeID <==== where is that ID coming from?

And it says "Hmm, that didn't work Something went wrong with connecting the Auth Provider to your account. Please give it another try."

I looked in login history and it shows that the login status was successful for the 'remote access client'.

I also looked at the auth provider settings in my sandbox instance and was not sure if this was because of an incorrect setting there.

Auth Provider Settings

I went under my user account and revoked trailblazer.me OAth connected App and tried again but no good. I also whitelisted the IP range it was showing under Login history for the Remote Access client but no good.

What can I do to trouble shoot this further?

FYI I do not have access to the production org. Could this be why?

1
  • I am also facing the same issue. Please share if you have a solution for this.
    – Aru
    Dec 23, 2021 at 6:09

1 Answer 1

1

My experience is that you cannot do this from a sandbox. I got the same error and when I tried everything from production the problem was solved. I have never seen such a frustrating mix of products as SFDC and myTrailhead - I still don't have it working to everyone's satisfaction. Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .