This is a very simple scenario i am working on. There is a custom formula field and i need to hide 2 related lists 'Deployment task' which is VF component and 'deployment steps' which is a standard related list based on the formula field = Salesforce then show the related list. I am so shocked that this simple condition is not working when i set this up in component visibility filter. The components are being displayed no matter even though the filter is applied on lightning record page. Any help on this is much appreciated. Thanks!

  • does the formula field's evaluation depend on inputs made to other fields on the Record Page?
    – cropredy
    Oct 29, 2021 at 4:40
  • 2
    Hi and welcome to SFSE. Do you mean they never change visibility or do you mean they do not change visibility during edit, only changing after save? Could you please edit your question to show the formula and the visibility filter that uses it plus explain whether this is at all times or during edit. Thanks.
    – Phil W
    Oct 29, 2021 at 6:23
  • @Himaja_Sfdc, I recently bumped into the same issue and after giving read access to the field it worked. Make sure your user has at least read access to the field. Here's the document describes supporting data types. help.salesforce.com/s/…
    – SL man
    Oct 13, 2022 at 6:14

2 Answers 2


I assume you may be using the Filter Type "Record Field." If you use the "Advanced" Filter Type, select Record in the field section and then find the field you want to drive the filter; this should allow the related list to show when appropriate.


If this is not answered here is the article. It will only hide formula field with certain condition. https://help.salesforce.com/s/articleView?id=sf.lightning_page_components_visibility.htm&type=5

These field types are supported:

-String type fields: Autonumber, Currency, Email, Number, Percent, Phone, Text, Text Area, URL -ID -Checkbox (boolean) -Geolocation -Picklist -Formula fields that resolve to one of these preceding types -Roll-up summary fields that resolve to one of these preceding types

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .