how to add view access to Dashbord in Salesforce for a profile? Why user cant see this dashboard? It is in public folder and on a profile there are enabled 'give view access to reports in public folders' and 'give view access to dashboards in public folders'.

enter image description here

When I enabled 'Manage Dashboards in Public Folders' for a profile, the user with this profile is able to see the dashboard, but now he has edit access, while I need only view access. So how to remove edit access and only keep view access?

enter image description here

2 Answers 2


Answer for your first question

(For non public folder dashboards) Go to that dashboard stored dashboard Folder >> Click Share option then you can mention the user/Role/Roles and internal subordinates options to share the dashboard into other users with access as View, Editor and Manager.

Answer for your Second question

I can guess following points are possible to missing,

  • Dashboard Running User is missing in your dashboard. Please ask admin to set dashboard Running User as Specific user or Login as user by clicking the gear icon for the dashboard edit page. Which will decide which user context the dashboard data need to show.

  • If it's come from any package, please check the package access for the specific user.

  • Please check the dashboard component using source report are coming from public folder or any shared folder. Because if Source reports are stored in any specific shared folder means, the users which view this dashboard need those report (source report) access to view the dashboard components.

Please let me know if it helps.

  • I enabled 'Manage Dashboards in Public Folders' and now user can see the dashboard, but now he has edit access, so how to remove edit access and only keep view access? User has access to all dashboard and report folders.
    – Tema1995
    Commented Oct 26, 2021 at 14:59

For Second Question

Ans:- Disable edit access in system permission under profiles.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .