1

SFX command is not able to load or use any one of them and throws the following error

Command 'SFDX: Authorize an Org' resulted in an error (command 'sfdx.force.auth.web.login' not found)

enter image description here

I tried to update SFDX by this command sfdx update and restart VS Code multiple times with no luck.

3
  • What is your vscode extension pack for Salesforce version? Commented Oct 9, 2021 at 13:12
  • @MohithShrivastava v52.17.0 Commented Oct 9, 2021 at 13:27
  • Are you already set default browser for your computer? Because some time if you not ser default browser, it's also cause this issue.
    – Raj
    Commented Oct 9, 2021 at 15:24

2 Answers 2

0

I tried too many steps that have been mentioned on the internet such as:
1-sfdx update.
2-reinstall sfdx cli plugin.
3-restart VS code.
4-and I also I tried to use commands instead of VS code.

but all of previous steps didn't work until I deleted the usernames.json files in the following path:

C:\Users\myUser\.sfdx

(i.e you will find each user name that you used to login as a .json file)

-2

sfdx force:auth:web:login

Not dot notation

1
  • 2
    The asker is using the Visual Studio Code command palette, not the command line.
    – David Reed
    Commented Oct 9, 2021 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .