Below you'll see the result of auto-complete operation by using the Google Location Service:

enter image description here

After typing "mokotowska 1" I got a correct result, choosing which resulted in filling all the address fields. What I am concerned about is that the Billing Street field's format is incorrect regarding my locale (Poland, it's set in my User Profile). It should be "Mokotowska 1" instead of "1 Mokotowska".

Is there any way to customize this setting? Tried looking it up in Setup, but not too much options to be honest:

enter image description here

1 Answer 1


It looks like it cannot be changed, I contacted SF support regarding this problem. Here's their answer:

From what I can understand:

You want to change how the address appears in the "Maps and Location Services (powered by Google)" feature.

Currently it is as below:

House Number, Street name, City

And you want to set it as:

Street name, House number, City.

Per my knowledge this is working as designed.

I have tried to find a way to change that but I am unable to find a workaround to update how it appears.

I request you to please contact an internal developer who can assist you with this since there is no standard functionality in the UI to change that setting.

If you want, you can put it up as an Idea with Salesforce so that our Product can take it into consideration and start working on it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .