0

I'm unable to add data to Data extension using API. I tried multiple times from postman, however I'm getting same error. I'm I missing something here?

{
    "documentation": "https://developer.salesforce.com/docs/atlas.en-us.mc-apis.meta/mc-apis/error-handling.htm",
    "errorcode": 0,
    "message": "Not Authorized"
}

My Data extension is as follows: enter image description here

Postman API call: enter image description here

Headers:

enter image description here

2
  • what is the scope of your installed package and what is the account context and does it match the account the DE is in
    – EazyE
    Oct 6, 2021 at 14:40
  • @EazyE We only have one BU, and the data extension scope is set to Read, Write Oct 6, 2021 at 14:46

1 Answer 1

2

You have a 401 status code in the response, which means based on documentation for handling API errors:

The token was not found in the request, or it is invalid or expired.

or

Ensure that access token is passed in the request header.

So check your Postman's variable {{access_token}} within the current environment:

  • Are you actually receiving the token?
  • Are you setting it into variables correctly?
  • Is the variable name correct?
  • Token expires in 20 minutes, maybe just refresh the authentication request would solve the issue
  • You can also try moving variable {{access_token}} to the "Authorisation" tab (before the "Headers" tab), where you would select the "Bearer Token" option from the dropdown

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .