3

When executing sfdx force:package:version:create to create a (namespaced) unlocked package version I am getting the error bellow:

ERROR running force:package:version:create:  Multiple errors occurred:
(1) CL_Admin: Cannot create permission set group components since the following permission set names are invalid: Account_Create, Account_Delete, Account_EditAllFields, ...

The only thing in common among all permission set names is the existence of the underscore character so I tried to remove but the error persists.

Has anybody seem this error before?

1
  • Same happened to me while trying to create a 2GP managed package. Did you find a solution for this? Commented Feb 24, 2022 at 19:13

1 Answer 1

0

As I have seen, this may be a SF Bug affecting to both 1GP and 2GP in different ways:

About 2GP:

I was able to workaround this issue by doing it in 2 steps:

  • 1º Create a package version (can be a Beta) containing only the permission set
  • 2º Create a newer version, now including the permission set group that contains the permission set.

About 1GP:

There is a similar issue in 1GP, but related to the deployment. It cannot be deployed a PSG an PS in the same deployment, it has to be done in 2 steps as well (1º PS and then PSG). That's where we got the idea to try something similar in 2GP that ended up working.

3
  • Do you know something else than this workaround ? I have the same issue with force:source:push of namespaced sources :/ Commented Sep 6, 2022 at 15:53
  • Sorry @NicolasVuillamy I don't have another solution. Only other option I can think of is creating a Salesforce case. Commented Sep 8, 2022 at 12:32
  • @NicolasVuillamy I am facing the same issue on pushing the source to the namespaced org. This is an SFDX bug to me. Logging an issue on github.
    – Hamza
    Commented Nov 11, 2022 at 12:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .