I cant see the SFDX Commands like deploy to server, retrieve from server. Authorization to the sandbox was successful yesterday. When I try to deploy my code from the same workspace in vs code today, I don't see the option to do so.

To overcome this, I need to create a new project and authorize the org again and deploy today. But this is not the right way to do this. Can anyone of your advise how to overcome this.

  • 2
    Did you wait for a moment for the Apex Language Server to start? The commands are typically not available for up to a minute after opening VS code while everything initializes.
    – sfdcfox
    Commented Sep 7, 2021 at 17:25
  • Make sure you are working on a SFDX project with the latest version of Salesforce CLI (developer.salesforce.com/tools/vscode/en/troubleshooting)
    – Vinay
    Commented Sep 7, 2021 at 23:06

3 Answers 3


This happens when you load the VS Code and immediately try to work. It takes a good 5+ mins sometimes for the VS Code to load the plugins like Salesforce CLI and SFDX.

To not have this issue, update your VS code and extensions to the latest version and restart it.


I found this thread on GitHub which solved the issue for me... https://github.com/forcedotcom/salesforcedx-vscode/issues/71

Specifically, I had to open the app folder that contains the sfdx-project.json as a top-level folder in VS Code.

  • Please reproduce the important parts of that link here. Links tend to go dead over time, so including the information here means that this answer can still be useful after that happens.
    – Derek F
    Commented Jul 2, 2023 at 11:33
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – identigral
    Commented Jul 2, 2023 at 16:41

If you have installed JDK 17, Salesforce CLI extension and VSCODE . Uninstall all of them . And reinstall in below manner Reinstall VScode Reinstall JDK and make sure variables are set in the variable path . Reinstall the Salesforce CLI extension package .

It worked for me. Hope it helps you too

For more and better info . Check the below link too.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .