0

We have created a custom object with a lightning page where we have included dynamic components - ie. filtered according to the value in a picklist field. We are receiving the error in sandboxes while creating/editing custom object. It was working before new release ,suddenly stopped working and Getting below error.

Filtering based on picklist values using field selection option in lightning experience page

  1. Logged in from custom profile
  2. Click on new button/edit button
  3. Getting below error

Looks like there's a problem.

Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details.

Error ID: 1413084233-221415 (1386041698)

I have verified profile and flexi page access everything Looks okay. As a salesforce admin, its working as expected. Any Suggestions why itsnot working for custom profiles?

Based on @Kris answer, tried same thing in my org but No Luck. Still Issue exist

5
  • 2
    Please include any relevant details. Error Id, specific errors from the Developer Console (F12), what you're filtering on, etc. The more detailed you are, the better the odds are we can help you with your problem.
    – sfdcfox
    Sep 5 at 5:20
  • error in Lightning experience page (flexi page). Once we click button new and edit button of the record we are getting error. Sep 5 at 5:32
  • @sfdcfox updated the question Sep 5 at 5:36
  • To resolve the issue, Can you please remove the Activity Component and add it back again to record page. Let me know if this helps!
    – neha rai
    Sep 5 at 8:11
  • I tried but it didnt work Sep 6 at 4:18
2

Based on that gack Id, it's related to the same underlying change from Winter '22 in this question.

For the profiles that receive that error, they'll need to be given the new View DeveloperName permission.

Admins, and other standard profiles with the Salesforce license, get this permission added automatically. Custom profiles, on the other hand, will need it to be enabled.

I can't answer for sure, but there's some dependency that is loaded on the edit/new (ex. Actions & Recommendations) for that object that is enforcing this new permission - you can see the full list of objects that enforce this new permission. If you use network inspector, you may be able to get some error information that could point to the specific object.

5
  • I had given the developer name or view set up configuration through permission set,still same issue: Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 957509425-94310 (1386041698) Sep 7 at 2:27
  • I would put in a case. You could try giving the enabled permission through profile vs. permission set to see if that makes any difference, but it seems it'll need more investigation. Sep 7 at 18:39
  • I have tried through profile and permission set also. still its not working Sep 8 at 5:53
  • Looks like they may have recently patched some behavior around this - if you check your instance and see that you're on Winter '22, patch 5 and still see the error/behavior - definitely create a case. Sep 8 at 23:32
  • 1
    I have already created a case and waiting for response Sep 9 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.