0

I am trying to determine how to send null data to a numeric column with a UTF-8 formatted file. When that same column was sent across not in UTF-8 it loaded fine. Now I get an error "Invalid Number" for those rows that don't have a value. I was told to put a 0 but we don't want a value of 0 for the rows that don't have an actual value.
We have to have UTF-8 because of another column that has accent values. Does anyone have any ideas of how to handle this? This is being loaded through Contact Builder-Data Extension.
I am new at this, so hopefully I have provided you with enough information. Thanks for any ideas you have.

4
  • 1
    Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Sep 3, 2021 at 15:09
  • Hello @KathyB, can you provide related assets to your issue, e.g. sample of the anonymized data you are trying to import, data extension's structure, and import definition configuration? Without those, it is unlikely to get a reasonable answer that would really solve your problem.
    – Niko
    Sep 4, 2021 at 16:53
  • I have a column in Teradata that is decimal(10,0). It may have a value and it may be null, it does not default to 0. The SFMC data extension has it as a numeric value and shows that nulls are acceptable. When sending the column to SFMC it is failing when a row doesn't have a value. The error is "Invalid Number". The file did load without an error before I had to switch it to a UTF-8 formatted file. The UTF-8 was due to another column with accented data that was not going into SFMC correctly. So, I fixed one problem but created another. I hope this makes sense.
    – KathyB
    Sep 7, 2021 at 14:21
  • The column may have values like 2154763 or 610 or null. The Data Extension that receives it will need to be the same. I can't have 2154763 or 610 or 0. I need to understand how in my file being exported out of Teradata and then imported into SFMC would show the null value. I tried even making the column as character and sending a blank but that didn't work.
    – KathyB
    Sep 7, 2021 at 14:25

1 Answer 1

0

A null value in salesforce via CSV is represented by #N/A Can you replace the values with this and try ?

Here is where you can get more info

3
  • Thanks Sid. I tried the #N/A on the file, which is txt and tab delimited. It did not recognize that as a null. Maybe I should use a different delimiter also, or do we need to switch the file to CSV for this to work?
    – KathyB
    Sep 9, 2021 at 19:21
  • Yes the salesforce system would like a CSV where any null is sent as #N/A
    – Sid
    Sep 9, 2021 at 22:51
  • Thank you. I will work with the person next week who is receiving the file and bringing the data in to Salesforce. I appreciate you taking the time to provide this help. I will let you know how it goes.
    – KathyB
    Sep 10, 2021 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .