When I update node.js to 16.8.0 on an existing program heroku is unable to build the environment and throws the following error:

npm ERR! sha512-uDE+ma9xOMfF4ncJHoymBWA084DqoO8q/hBDvGx4WUxmvFQfHoCsk3BYk1D1Lei/lhNCZXLf1vkeNYVBSqrSgw== integrity checksum failed when using sha512: wanted sha512-uDE+ma9xOMfF4ncJHoymBWA084DqoO8q/hBDvGx4WUxmvFQfHoCsk3BYk1D1Lei/lhNCZXLf1vkeNYVBSqrSgw== but got sha512-XL7d6nOKYiv1Q8hQAylQFvnj70V0i+RwIPfLv0IqtR3Q/a6VdRcilffWhL6lzENNdjgkM20PTfy/4RB24jJ1Ug==. (601430 bytes)

The program runs without issue locally. Any idea on what I could do to get this issue resolved? Thanks

1 Answer 1


Heroku - Cache Behavior

Heroku maintains a build cache that is persisted between builds. This cache is used to store caches for npm, yarn, and bower.

You can disable all caching for Node.js apps if you prefer:

heroku config:set NODE_MODULES_CACHE=false

Then, before redeploying try to uninstall/reinstall your package locally:

npm uninstall package_name

and then :

npm install package_name

  • I was able to successfully disable caching however I'm still getting the same error.
    – rvx15
    Commented Aug 30, 2021 at 22:17
  • try to uninstall/reinstall the package via npm locally
    – glls
    Commented Aug 30, 2021 at 22:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .