9

I have created a action to create a record on Opportunity object and added it to the page Layout as well but i am unable to see the quick action on the opportunity detail records

Can someone please advice if i am missing anything here

![QuickAction] Quick action on the page Layout

![Opportunity Record] Opportunity details

2
  • Does your profile have record type access to whatever record type the quick action may be using? Commented Aug 25, 2021 at 12:32
  • Hi @KrisGoncalves how do i know if i have access to that record type i am having system administrator profile
    – SFDCSai
    Commented Aug 25, 2021 at 13:07

2 Answers 2

20

It could be many things. Below is a general troubleshooting list for a quick action (QA) that doesn't appear on record pages:

  1. Does the user have access to the object the QA is creating?
  2. If it's Log a Call - does the user have Access Activities permission?
  3. If it's Send Email, does the user have Send Email permissions and is email deliverability turned "on" where you're testing?
  4. Does the user have record type access to the record type defined in the QA?
  5. If it's a VF, Aura, or LWC QA - does the user have apex access to the controller (if one is used).
  6. If it's a flow QA - does the user have the Run Flows permission or Flow User checkbox on their User record? Is the Flow activated? Does the Flow use Override default behavior and restrict access to enabled profiles or permission sets - does the user have relevant profile/perm set?
  7. Is the page layout you added the QA defined in the page layout assignment for your profile for that record type of the record you're testing on?
  8. Do you have a lightning page defined? Is it using dynamic actions? You'll have to add the QA to the dynamic actions on the lightning page itself.
  9. Is the object you added the QA to a Case, Work Order, or User? This works differently in where the QA appears as noted in Actions in Lightning Experience. Depending on if feed tracking is enabled, you may see the QA in the chatter tab - utilizing dynamic actions will let you put the QA where you'd like (see this answer)

Below are more details on how to check each of the above

  1. Setup --> Profiles --> UserProfile. Go to Standard Object Permissions or Custom Object Permissions to check it has create/update access.

enter image description here

  1. Setup --> Profiles --> UserProfile. Under General User Permissions, there's the Access Activities permission that needs to be checked.

enter image description here

  1. Setup --> Profiles --> UserProfile. Under General User Permissions, there's a Send Email permission. For Email Deliverability, go to Setup --> Deliverability and make sure Access Level is set to All Email

enter image description here

  1. Setup --> Profiles --> UserProfile. Go to Record Type Settings, do you see the record type listed next to the object? If not, click edit and add it.

enter image description here

  1. Setup --> Apex Classes --> YourApexClass. Click on Security and make sure the user's profile is added to the list.

enter image description here

  1. Go to your profile and, under General User Permission, check if Run Flows is enabled. Otherwise, go to the user record itself and see if Flow User is checked.

enter image description here

For checking "override default behavior" - click on down arrow on Flow, select "Edit Access" and see which profiles are enabled

enter image description here

enter image description here

  1. Setup --> Object Manager --> YourObject --> Page Layouts. Click Page Layout Assignment and confirm the page layout you updated is assigned for the record type of the record you're on (not necessarily the one you may be creating in the QA).

enter image description here

  1. Setup --> Object Manager --> YourObject --> Lightning Record Pages. You may need to look at View Page Assignments or what is the Org Default page, but once you figure out which page is displayed to your user, click into it and edit it. On your highlights panel, do you see an Add Action button or an Upgrade to Dynamic Actions. If you see an Add Action, you'll have to add your QA there.

enter image description here

1
  • I have to acknowledge this is superb Commented Jan 31 at 20:54
2

I had a similar issue but none of the fixes mentioned worked for me. After hit-and-trial, I found out that there is a lookup field on the child object (being created) from QA on the parent object, that didn't had the edit access on the profile. After giving the required access the QA started appearing (lookup field is not required yet the QA disappeared).

  • Go to the affected profile > Object settings > Select Object > Field Permissions > Make sure that the field has edit access on the profile.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .