2

My package is on a developer organization, it's marked as managed, and the namespace is FBO. I've uploaded the package and I can install it successfully through the URL. Since I need to automate the installation, I'm using the metadata API.

When I install my managed package through the metadata API into other Salesforce instances, the deployment result is a success but it says that no components were installed, and no failures. My zip file has the folder "unpackaged" which contains the file "package.xml" and the folder "installedPackages". That folder has "fbo.installedPackage" inside it.

Here are my file contents:

unpackaged/package.xml:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>*</members>
        <name>InstalledPackage</name>
    </types>
    <version>52.0</version>
</Package>

unpackaged/installedPackages/fbo.installedPackage:

<?xml version="1.0" encoding="UTF-8"?>
<InstalledPackage xmlns="http://soap.sforce.com/2006/04/metadata">
<versionNumber>1.0</versionNumber>
<activateRSS>false</activateRSS>
</InstalledPackage>

I've been beating my head against this and can't find anyone else running into a similar issue. I can install other managed pacakges through my metadata client on the target org, just not the one I'm developing.

6
  • You don't need to HTML-encode your source, just highlight it and use the {} (format code) button, it'll come out right on our end.
    – sfdcfox
    Aug 2, 2021 at 21:31
  • Is your namespace FBO or fbo? The namespace is case sensitive.
    – sfdcfox
    Aug 2, 2021 at 21:34
  • Thanks, I'll do that in the future! The documentation I read stated it wasn't case sensitive. It's FBO though. I'll try it as FBO Aug 2, 2021 at 21:41
  • Still no luck when using FBO.installedPackage Aug 2, 2021 at 21:43
  • Do I have permission to attempt to install your package in my developer org? I'm willing to help, but we don't have enough info as is.
    – sfdcfox
    Aug 2, 2021 at 21:43

1 Answer 1

1

I don't know if this will help you, but I successfully installed your package. Keep in mind that literally everything in the Metadata API is case sensitive. Here is the ZIP that I used to install your package:

UEsDBBQAAAAAAH1+AlMAAAAAAAAAAAAAAAAXAAAAdGVtcC9pbnN0YWxsZWRQYWNrYWdlcy9QSwME
FAAAAAgAfX4CUxRqMd2VAAAAzQAAACsAAAB0ZW1wL2luc3RhbGxlZFBhY2thZ2VzL0ZCTy5pbnN0
YWxsZWRQYWNrYWdlXY7NCsIwEITvgu8QcrcbRUQkTW+CFxGrD7Cm21rMT2nW4uObgwd1jsPMfKOr
l3diojH1MZRyWSgpKNjY9KEr5fWyX2xlZeYzfQiJ0TlqTmgf2JHIvZBKeWcedgAp4lCkNo6WChs9
rJTagFqDJ8YGGWXeEFn6gzo+/Y1Gk3kafq1PDi33EzKd69q06BJp+LbyI/i/ZN5QSwMEFAAAAAgA
mX0CU0bgl6ugAAAA6gAAABAAAAB0ZW1wL3BhY2thZ2UueG1sTU/BCsIwDL0L/kPpUbCpQ0Wk626C
Nw/6AbGL23Btx1pE/94yOlhOeS957yWq+tqefWgMnXcl3wnJGTnj6841JX/cL9sTr/R6pW5o3tgQ
S+sulLyNcTgDBI+DCC8/GhLGWyikPILcg6WINUbkScpSqfgbKGQwEZbsM6XqjYK5XUwdWtJXFyL2
PdU5W8FEZ0dYWqr8gT4UQiqYUbobslj/AVBLAQIUABQAAAAAAH1+AlMAAAAAAAAAAAAAAAAXAAAA
AAAAAAAAEAAAAAAAAAB0ZW1wL2luc3RhbGxlZFBhY2thZ2VzL1BLAQIUABQAAAAIAH1+AlMUajHd
lQAAAM0AAAArAAAAAAAAAAEAIAAAADUAAAB0ZW1wL2luc3RhbGxlZFBhY2thZ2VzL0ZCTy5pbnN0
YWxsZWRQYWNrYWdlUEsBAhQAFAAAAAgAmX0CU0bgl6ugAAAA6gAAABAAAAAAAAAAAQAgAAAAEwEA
AHRlbXAvcGFja2FnZS54bWxQSwUGAAAAAAMAAwDcAAAA4QEAAAAA

Save this to a file like "example.b64", then decode this with the command:

base64 -d example.b64 > temp.zip

Then decompress:

unzip temp.zip

And then try deploying:

sfdx force:mdapi:deploy -d temp -w 10 -u user-alias

You can also compare the files to my own and see if there's any difference.

These commands were ran from Github Bash Shell (included in Github Desktop), using sfdx-cli/7.110.0 win32-x86 node-v14.17.0

1
  • That worked first try. Thanks a ton, I've been beating my head against this for an embarrassing amount of time. Aug 2, 2021 at 22:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .