1

My colleagues and I are unable to get into the workbench page https://workbench.developerforce.com/streaming.php as we get the following error:

enter image description here

I've checked the workbench code and all it does is to check that the running user has permissions to SOQL the PushTopics. We're System Administrators and I've double-checked that the SOQL returns records for us.

The ORG has both the "REST API" and "Streaming API" enabled.

Any idea what can it be?

For the record, the error message is "Could not load Push Topics. Ensure the both the REST and Streaming APIs are enabled for this organization." and it can be found in the line 58 of the StreamingController.php file (https://github.com/forceworkbench/forceworkbench/blob/main/workbench/controllers/StreamingController.php)

4
  • Workbench is not officially supported by Salesforce. Streaming API subscription with Workbench is sometimes flaky and salesforce no longer recommends using Workbench. Can you use the EMP Connector and see if the issue still persists. Example
    – Swetha
    Jul 29 at 11:11
  • Additionally, I have seen a similar issue in past wherein enabling the Edge Network fixed this error in workbench. Recommend testing in the sandbox first.
    – Swetha
    Jul 29 at 11:22
  • 1
    Thanks @Swetha, using EMP Connector works flawlessly but it's much less friendly. Edge Network is enabled too, btw. I know it's not supported by Salesforce so that's why I went here instead of creating a ticket there :) If there's someone else that knows or can help I would appreciate, otherwise I'll mark your answer as the good one Jul 29 at 13:23
  • Thanks for confirming
    – Swetha
    Jul 29 at 15:03
0

Summarizing posted comment:

Workbench is not officially supported by Salesforce. Streaming API subscription with Workbench is sometimes flaky and salesforce no longer recommends using Workbench.

The recommendation is to use the EMP Connector, which is a Java client tool and also open-source to fix the issue. See example here

In few scenarios, enabling the Edge Network does the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.