2021-07-26, hundreds of orgs reported being affected by this Known Issue

Summary As of Chrome version 92, customers may experience issues when working across the Salesforce platform. This impact may appear with buttons that were previously functioning as expected, visualforce pages/components, or other content not performing as expected. In the Chrome developer console logs impacted users will see the following error:

A different origin subframe tried to create a JavaScript dialog. This is no longer allowed and was blocked. See https://www.chromestatus.com/feature/5148698084376576 for more details.

Are there any other workarounds besides those listed?

  • Similar error could be happening for aura components, where opening link in a new tab is getting blocked. Although not everyone could be facing this.
    – Cloud Man
    Commented Jul 27, 2021 at 19:17

2 Answers 2


A common reason for the non-functional buttons is the "Are you sure" javascript dialog that you might see encoded on a VF page commandButton like this:

<apex:commandButton action="{!doSomething}" value="Do Something"
                    onclick="if(!confirm('Are you sure?')){return false};"

Not all of the workarounds suggested in the Known Issue may be applicable/practical/possible to your org:

  • Using Firefox or Safari
  • Changing the way Chrome is launched

An additional workaround that I have discovered (besides removing the confirm JS function from custom buttons) is to run the application page in SFDC Classic. This also addresses the Reset Password button issue which appears to use the JS confirm dialog mechanism

Note: The Classic workaround does not "work" in Service Console Classic;


It has been observed that if you have a JS call before page postback are not working in Chrome 92, especially in cross domain scenario.

Try below workaround.

Chrome (icon)--> Properties --> Shortcut Tab -->Target Textbox. You will see below setting in TargetTextbox "C:\Program Files\Google\Chrome\Application\chrome.exe"

After that setting add below line. Restart Chrome and check.


Javascript alert, confirmation box work with these settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .