0

Please help me with this, I checked everything in the formula and the same formula field is showing in SIT org but not in UAT org. I checked the field permissions but it seems all have the access. What could be the issue? I can't figure it out.

IF( 
    OR(
        ISNULL(DL_Name__c), 
        ISBLANK(DL_Name__c)
    ) , 
    DL_Perpetrator__r.Person_Name__c, 
    DL_Name__c
)

DL_Perpetrator__r.Person_Name__c - this field already has the value and DL_Name__c is coming as blank. So ideally it should show up DL_Perpetrator__r.Person_Name__c value.

Please, help or suggest what I need to check more here.

6
  • Try to display DL_Perpetrator__r.Person_Name__c and DL_Perpetrator__c as two separate fields to debug. I suppose it should mostly drill down to access issues in two different envs. Jul 23 at 10:10
  • Thanks but I am able to get the value in DL_Perpetrator__c as well.
    – user91530
    Jul 23 at 10:58
  • you know you can vastly simplify your formula to: BLANKVALUE(DL_Name__c, DL_Perpetrator__r.Person_Name__c)
    – Nick Cook
    Jul 23 at 11:00
  • I tried IF(ISBlank(DL_name__C),DL_Perpetrator__r.Person_Name__c,DL_Name__C) but still can't get the value. Also in another org it is working fine cant understand why it cant work in uat
    – user91530
    Jul 23 at 11:03
  • 1
    How is your formula set to handle blank values? Is it leaving blanks as blanks, or converting blanks to 0? This is controlled by a set of 2 radio buttons at the bottom of the page when you create/edit the formula.
    – Derek F
    Jul 23 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.