After successfully setting up Einstein Activity Capture (for Google) on my production org, I then created a sandbox for it.

enter image description here

In the sandbox org, when I go to Einstein Activity Capture in Settings, the message shows to "Turn off Lightning Sync"

enter image description here

I turned off GMail/Outlook integration and don't see any other option to turn off Lightning Sync. How do you enable Einstein Activity Capture in a sandbox org?

Thank you

  • if you go to Setup --> Outlook Integration & Sync, are you able to turn off lightning sync? Jul 6, 2021 at 16:14
  • It says "Lightning Sync is no longer available for setup", same message as for Gmail.
    – T. Webster
    Jul 6, 2021 at 16:25
  • 1
    You can try disabling through EmailIntegrationSettings in the Metadata API. You can retrieve (using workbench or VS code) with the package.xml identified here. I presume enableContactAndEventSync will be true on retrieve. Change that to false and deploy. Jul 6, 2021 at 17:12
  • @KrisGoncalves you're correct, the enableContactAndEventSync was true. Einstein Activity Capture now works. Thank you. If you'd like to post your answer, I'd be happy to accept.
    – T. Webster
    Jul 6, 2021 at 18:57

1 Answer 1


Since the UI isn't behaving, you can disable this through the Metadata API with the EmailIntegrationSettings metadata type.

The field you're interested in is enableContactAndEventSync. This'll return true assuming Lightning sync is actually activated and preventing you from activating Einstein Activity Capture.

Within VS Code (or whichever deployment means you'd like), retrieve with the following package.xml

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">

This'll create a Settings folder wtihin your project (if you've never pulled anything in before).

Change enableContactAndEventSync to false within the EmailIntegrationSettings file, re-deploy, and this should deactivate Lightning Sync. Thus, allowing you to go through the EAC setup within the UI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .