0

please I am having issues installing and running Dataloader on my MacOS Big Sur. I have downloaded and installed Zulu. I have also downloaded and installed Dataloader but when I run it, I get the error: DATALOADER_WORK_DIRECTORY_PLACEHOLDER: No such file or directory Error: Unable to access jarfile dataloader-52.0.0-uber.jar How do I fix this please? Thank you.

2 Answers 2

1

Go to System Preferences ->Security&Privacy ->Privacy ->Full disk access and Files and Folders and add Zulu java to it.

4
  • Thank you for your answer. The problem is I can't select the whole zulu folder so what file in the folder do I select?
    – Afe
    Jul 4, 2021 at 15:39
  • The java executable
    – Rajiv
    Jul 4, 2021 at 16:25
  • The java executable files are greyed out. I can't select them.
    – Afe
    Jul 9, 2021 at 3:32
  • Yay! I found a solution. I follow these steps exactly. Scroll down to the section "Running Data Loader on Mac M1 Hardware" (developer.salesforce.com/docs/atlas.en-us.dataLoader.meta/…). I tried these steps before but for reason, they worked now.
    – Afe
    Jul 16, 2021 at 6:55
0

Go to the Directory in which you have the Dataloader folder. then on the terminal run below command -

chmod 777 YourDataLoaderFolderName

For example, if my Dataloader folder is on Desktop it will be like this -

Desktop %     chmod 777 dataloader_mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .