0

I'm unable to update my sfdx cli.

Installed via the installer here: https://developer.salesforce.com/tools/sfdxcli

I've tried uninstalling via the instructions provided, but sfdx remains installed. I've tried reinstalling via the installer, but the sfdx version remains the same.

Is there any way to get my sfdx cli up to date?

MacOS version 10.14.6 sfdx cli version 7.92.0

3

The same happened to me a few days ago (stuck in CLI 7.94.3 without updates via sfdx update)

My fix: Check your installation method(s) (via npm/yarn or via the installer).

The 'which' command will point to the bin directory containing sfdx

$ which sfdx

If yarm/npm: remove the CLI:

$ yarn global remove sfdx-cli

or

$ npm uninstall -g sfdx-cli

If installed via the installation program: as already done follow the CLI Setup Guide instructions

sudo rm -rf /usr/local/sfdx
sudo rm -rf /usr/local/lib/sfdx
sudo rm -rf /usr/local/bin/sfdx
sudo rm -rf ~/.local/share/sfdx ~/.config/sfdx ~/.cache/sfdx
sudo rm -rf ~/Library/Caches/sfdx

This will keep the login information contained in your ~/.sfdx directory

Then reinstall from https://developer.salesforce.com/tools/sfdxcli and if required

$ sfdx update

or

$ sfdx update stable-rc

to use the Release Candidate version.

Hope this can help

$ sfdx version --json

{ "cliVersion": "sfdx-cli/7.108.0", "architecture": "darwin-x64", "nodeVersion": "node-v14.17.1" }

1
  • This worked for me when I did a restart after uninstalling
    – Elliot
    Jun 28 at 14:45
1

Had you tried Sfdx update ? Additionally, when you uninstall a CLI make sure you close your existent terminal and open a new one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.