1

We are not using the new custom Service Not Available Page in Experience Bundle (as we do not have a CDN enabled). We're getting the following error while trying to install our package:

"Your site needs a route with route type service-not-available. Update your file and try again."

Attempting to install a package version that worked a few weeks ago no longer works.

Documentation for the Service Not Available Page says "The Service Not Available Page also exists as a service-not-available route type in the Experience Bundle. Developers must update their file in order to avoid getting an error on missing this route type." But when we pull down from our scratch org, we don't have a serviceNotAvailable route. What am I supposed to be updating? Am I supposed to generate the route from scratch? What kind of metadata?

1
  • The answer in this seemingly unrelated posting covers what you need to do. You need a special feature to enable the pull/retrieve.
    – Phil W
    Jun 25 at 21:28
0

To provide just this aspect for future searchers, here's my experience with this issue when I got it with my packaged experience builder site:

  • I kept my sfdx-project.json's sourceApiVersion as 51.0. Trying to change this to 52.0 caused me problems with incompatible metadata at the very least in the site-meta.xml.
  • I added "PublishAuraExpBuilderBasedSna" as a feature in my project-scratch-def.json. I rather expected this to cause issues with the source version of 51, but it didn't.
  • After creating my scratch org and deploying the metadata I did a conditional retrieve of metadata to get the updated version of the Build Your Own theme (buildYourOwn.json) within the experience bundle. This update adds the now-mandatory "ServiceNotAvailable" layout and its related view.

I didn't actually need any other metadata changes at all, managed to create a new version of the unlocked package and installed this successfully onto a Summer '21 scratch org.

3
  • Will try this and let you know! thank you!
    – SRenberg
    Jun 26 at 20:11
  • Note that I your experience is LWR-based remove Aura from the feature name.
    – Phil W
    Jun 26 at 20:50
  • Yes, this solved the issue. Thank you so much!
    – SRenberg
    Jun 27 at 17:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.