2

I am attempting to create a Quick Action using LWC without using Aura however I am getting a error. I was reading the documentation https://help.salesforce.com/articleView?id=release-notes.rn_lwc_quick_actions.htm&type=5&release=232

When I change the js-meta.xml for action Type

<?xml version="1.0" encoding="UTF-8" ?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata">
<apiVersion>52.0</apiVersion>
<isExposed>true</isExposed>
<targets>
   <target>lightning__RecordAction</target>
</targets>
<targetConfigs>
<targetConfig targets="lightning__RecordAction">
 <actionType>Action</actionType>
</targetConfig>
</targetConfigs>
</LightningComponentBundle> 

Error

Invalid element name:

  • actionType

One of the following is expected:

  • hasStep
  • objects
  • property
  • propertyType
  • supportedFormFactors

Error indicated by: {http://soap.sforce.com/2006/04/metadata} with code:xml(cvc-complex-type.2.4.a)

2
  • 1
    Did you make sure your org is on v52? Did you make sure your metadata and API settings are set to v52?
    – sfdcfox
    Commented Jun 17, 2021 at 19:39
  • This error is fired by linter in VS Code, but you should be able to deploy and use the component. Commented Jun 18, 2021 at 8:37

1 Answer 1

0

This error does not restrict you from deploying the component. Seems like the linter extension is not updated to support this. But you can definitely deploy this component to an org.

Note that the org has to be in the Summer 2021 release.

Not the answer you're looking for? Browse other questions tagged .