0

I'm trying to install package through pipelines for Scratch org push & test. I'm using this command in our yml file -

sfdx force:package:install --package 04t1Q000000kYu4 -w 10 -u ciorg

Here is full line from yml file -

createScratchorg: &createScratchorg sfdx force:org:create --definitionfile config/project-scratch-def.json --setalias ciorg --wait 10 --durationdays 1 && sfdx force:package:install --package 04t6g000008SbHP -w 10 -u ciorg && sfdx force:package:install --package 04t1Q000000kYu4 --securitytype AllUsers -w 10 -u ciorg && sfdx force:source:push --targetusername ciorg && sfdx force:apex:test:run --targetusername ciorg --wait 10 --resultformat json --codecoverage && sfdx force:org:delete --targetusername ciorg --noprompt

I've added component from this package on custom object's record page and I get this error -

Error force-app/main/default/flexipages/PurchaseOrderRecordPage.flexipage-meta.xml We couldn't retrieve the design time component information for component NEILON:edLightningFileExplorer

I suspect it might be related to access settings. During installation, it asks Grant access (y/n)?

I can't interact with pipeline installation so I assume it might be set to n by default. I was googling for parameters that might be useful in this situation but I didn't find any. Has anyone had similar problem or knows what I could do?

1
  • What is the component from the managed package that you are trying to use on the Lightning record page?
    – Swetha
    Jun 11 at 11:58
0

To cater "I suspect it might be related to access settings. During installation, it asks Grant access (y/n)?", try below:

If you're using shell script, you can try below -

echo y | sfdx force:package:install --package 04t1Q000000kYu4 -w 10 -u ciorg
5
  • &createScratchorg sfdx force:org:create --definitionfile config/project-scratch-def.json --setalias ciorg --wait 10 --durationdays 1 && sfdx force:package:install --package 04t6g000008SbHP -w 10 -u ciorg && ECHO y | sfdx force:package:install --package 04t1Q000000kYu4 --securitytype AllUsers -w 10 -u ciorg && sfdx force:source:push --targetusername ciorg && sfdx force:apex:test:run --targetusername ciorg --wait 10 --resultformat json --codecoverage && sfdx force:org:delete --targetusername ciorg --noprompt Im not sure if I put ECHO in the right spot. I get bash: ECHO: command not found.
    – jacob1342
    Jun 14 at 11:41
  • probably you're putting all in single command. lets break whichever command possible and then execute it.
    – Ysr Shk
    Jun 14 at 11:46
  • same thing I have done and working (providing the Y input on waiting of program) on windows and linux machines. So I don't think its an issue in that approach.
    – Ysr Shk
    Jun 14 at 11:46
  • 1
    It worked. I just needed to change it to lower case letters. Thanks!
    – jacob1342
    Jun 14 at 12:45
  • Updated to lowercase, considering your scenario :-)
    – Ysr Shk
    Jun 14 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.