0

I am trying to query feed-elements via Rest API from the workbench. API ref

/services/data/v51.0/chatter/feeds/record/5001x00000CA8IGAA1/feed-elements?customFilter=CustomFeed

I am getting this error.

[ {
  "errorCode" : "INVALID_FIELD",
  "message" : "Invalid custom filter name. "
} ]

This CustomFeedFilter is already available in ORG.

<types>
    <members>CustomFeed</members>
    <name>CustomFeedFilter</name>
</types>
0

Looks the 'recordId' mentioned in query doesn't exists in your org. I tried with same Id and got similar error.

enter image description here Please re-check the record id and use below query, you should be able to get results.

/services/data/v51.0/chatter/feeds/record/09Z6F0000004ddv/feed-elements

enter image description here

Thanks

2
  • Hi @Vinay The /services/data/v51.0/chatter/feeds/record/09Z6F0000004ddv/feed-elements URL is working fine, I am getting the results with base API query. But when I am passing the customFilter=CustomFeed params I am getting the error. Jun 22 at 11:23
  • I don't think this is the right format to pass, even when I tried using customFilter=CustomFeed I get the error. Also haven't found anything related documentation about error syntax.
    – Vinay
    Jun 22 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.