0

The failures are occurring for both our Continuous Integration (CI) builds and out interactive creates. The CI output is:

Run sfdx force:org:create -f config/project-scratch-def.json -a scratch-org -s -d 1

ERROR running force:org:create: We couldn't find a template with the ID specified in the scratch org definition. If you’re sure the ID is correct, contact Salesforce Support.

Error: Process completed with exit code 1.

and when I look at the corresponding Scratch Org Info records I see:

  • Status: Error
  • Error Code: C-1020

The scratch def is:

{
  "orgName": "MyOrg",
  "edition": "Developer",
  "language": "en_US",
  "features": ["SharedActivities"],
  "settings": {
    "opportunitySettings": {
      "enableOpportunityTeam": true
    },
    "lightningExperienceSettings": {
      "enableS1DesktopEnabled": true
    }
  }
}

I've found nothing useful Googling both:

  • We couldn't find a template with the ID specified in the scratch org definition.
  • C-1020

PS

Found the C-1020 here in SignupRequest documentation:

  • C-1020: Template not found. Either the template doesn't exist (or it was deleted).
4
  • 1
    It's an ongoing issue (affecting us too) - see the linked Known Issue on the question above.
    – David Reed
    Jun 9, 2021 at 17:14
  • Thanks @DavidReed very helpful. Note not a Communities org in this case.
    – Keith C
    Jun 9, 2021 at 17:17
  • Yeah, the Communities thing is a red herring. I believe the scope is orgs on a 232 pod but don't quote me on that :)
    – David Reed
    Jun 9, 2021 at 17:17
  • 1
    I have confirmed that the bug impacts all default 232 scratch org creation. The fix for the known issue will respect this scenario too. Thank you
    – Swetha
    Jun 9, 2021 at 20:39

0