1

I just created a new Org with an app that is still reliant on the Classic interface. I can easily switch back to Classic with the admin user, but with a new Salesforce Platform user, I cannot even see the option in the Lightning interface. Obviously, the first user is an admin, and the second isn't - but what gives?

Of course, I checked the profile of that user. "Hide Option to Switch to Salesforce Classic" permission is not enabled. "Remain in Salesforce Classic" is enabled. "Lightning Experience User" is disabled.

And just to be sure I just enabled ALL "General User Permissions". I also enabled all of "Administrative Permissions", except for the two options mentioned above. Nothing works. What am I missing?

0

As per this article, you will have to contact support for assistance

Check the User's profile if the "Hide Option to Switch to Salesforce Classic" permission is enabled. If the permission is not enabled, please contact Salesforce Support for assistance.

1
  • Hmm. Seems like I really have to contact support for this as there's no other option. But how weird that is. The article basically says: "Yeah. It might not work. Let us know if that happens." ... How odd.
    – Semmel
    Jun 8 at 14:55
0

This behaviour(Hide Option to Switch to Salesforce Classic is not working as expected) is been documented in the help article.

It's been observed that, when a user profile has the permission "Hide Option to Switch to Salesforce Classic" enabled, the user still has the option to switch to classic from the Avatar Menu.

Make sure these 3 permissions are disabled/enabled in the user Profile (as well as any assigned Permission Sets):

  • Manage Users.
  • Customize Application.
  • Modify all Data.

Note: Please leave the "Hide Option to Switch to Salesforce Classic" Checked.

1
  • I don't want to hide the option - quite the opposite, actually.
    – Semmel
    Jun 8 at 14:52
0

I reached out to Salesforce support and after a lot of back and forth over two months, they finally could pinpoint the exact problem. (Thanks guys!)

"Starting on the 11th of June 2018, all new Orgs created for Sales Professional Edition and Services Essentials editions will default to Lightning."

This automatically sets the hidden option "Users are Lightning Only" for the whole Org and prevents non-admins to switch to Classic. Interestingly this is even carried over when upgrading your Org to Enterprise Edition later on (which does not have this limitation) as described in this article: https://help.salesforce.com/s/articleView?id=000317164&type=1

You can open a support case with Salesforce to disable the "Users are Lightning Only" permission for your Org - which is exactly what solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.