1

I receive a problem in the targetConfig, when I enter the actionType it gives me an error that says it is an invalid element name. Do you know why that happens?

enter image description here

4

You need to specify version 52.0 in order to use this feature; see the release notes. Notably, this also means your org must be a Summer '21 version in order to deploy this feature.

3
  • We can also deploy with version 51.0, this error is just in VS code but I am able to deploy and use the component. Seems like the linter extension is not updated yet to support this. Also, the error does not go away even if we change the version to 52. Jun 18 at 8:35
  • @RahulGawale Ah, I thought it was the brand new 52 stuff. Most likely the extension is out of date? Have you tried updating to the latest version? Regardless, if it's just a client-side error, you can ignore it.
    – sfdcfox
    Jun 18 at 11:39
  • yes the extension is up to date and sfdx cli is also up to date. I have raised an issue on GitHub repo of VS code extensions. Till then we can just ignore the error as its client side. Jun 18 at 11:45
0

I turned off the Red Hat XML extension in my workspace and that problem vanished. The clue for me was "with code: xml(...)" in the Problems panel message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.