I've followed this Salesforce blog Drive your Testing Strategy with Code Coverage to get LWC and Apex code coverage numbers reported in Codecov via GitHub actions. The LWC part works well, but it appears that the Apex test results cause Codecov to get stuck "Processing...".

Have you experience and solved this problem for Apex?

(Yes I have a ticket raised with Codecov as well and will post any solution they provide here. But this appears to be Salesforce language specific i.e. Apex problem that someone on this site may have experienced.)

1 Answer 1


Codecov support think that this Salesforce change https://developer.salesforce.com/blogs/2021/04/clearer-apex-commands.html is tripping up their parser so will look at it a bit more. Apex is probably not a priority for them though, so this might stay broken.

But good work from Codecov support to engage with a customer presently on a free trial.

Based on the SF link, I've tried:

  • -r junit and that didn't fix it
  • -r tap and that didn't work
  • -r json and that didn't work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .