0

I'm having an issue where I want a user with an assigned permission set to be able to see fields in an object ("Read" Permission in Object Level), but I want 2 fields to be hidden ("Launch URL" and "Operation"). At a profile level, this object has no permission access, so with the permission set I'm allowing certain users to view the object/fields, but I want to hide the two that I just mentioned:

enter image description here

However, when I go to record detail page, I still see these fields after logging in to Salesforce with the user that has the permission set assigned. Any ideas why these fields could not be hiding?

Thanks very much!

11
  • Hi, @bonzi, welcome to Salesforce StackExchange. Could you please share the details of the permission set? I also recommend you to look at Control Access to Objects at TrailHead. The latter may already answer your question. Jun 1 at 10:35
  • Hello @JefersonChaves, thanks for your reply! What information regarding the permission set do you need? I have completed that Trailhead already, I also went over it but I can't see what I'm missing. Regards!
    – bonzi
    Jun 1 at 12:18
  • Sure thing, I believe the "Field Permissions" screenshot related to the profile, what about the Permission Sets assigned to the user in question? Can you please share the screenshot of the "Field Permissions" of permission sets assigned to the user? Jun 1 at 12:49
  • 2
    You say there are no object-level permissions in the profile, but have you cleared the field-level permissions in the profile also? Jun 1 at 15:29
  • 1
    @DavidCheng that was it! I had no object-level permissions in the profile but the field-level permissions were there, so that's what caused it. Thanks a lot to you and everyone for your input! :)
    – bonzi
    Jun 2 at 6:41
2

If there are field-level permissions in a profile, these will take effect as soon as you assign object-level permissions in a permission set. Thus, you'll need to clear the object's FLS settings in the profile even if you've disabled all object-level permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.