5

I have two content blocks in an email in Marketing Cloud. No matter what I do, there is a 1px white line between them on Outlook 2019 and Outlook Office 365 on Windows. The white line does not appear in Outlook 2007, 2010, 2013, or 2016. I need to eliminate the white line.

enter image description here

The white line is still present even if I switch the order of the content blocks

I have tried the following:

  • Set the content area background color to match the color of the content block background
  • Remove the content from all container tables, divs, etc.
  • Eliminate all odd-numbered heights and font sizes
  • Place both content blocks in the same content area
  • Place each content block in its own content area
  • Placing &nbsp; entities in front of closing </td> tags.
  • Setting tables to border-collapse

If I place the content of both blocks into a single block, the line goes away, which is why this is clearly and Marketing Cloud issue. I need the content in separate content blocks because they are dynamic and not everyone who gets the first block will get the second block, but some people will get both blocks based on their data fields.

2
  • 1
    Hi, the problem might lie in the type of block. What kind of content block are you using? free form? Try playing around with HTML instead; May 21 at 9:19
  • Are your content blocks wrapped in tables? It would be great if you could show some code. May 21 at 16:09
2

Although this is caused by SFMC, I think it is actually because of an Outlook bug. The dreaded 1px line.

There is not any really hard and fast solution to get it gone, but there are two leading theories that can help remove or hide it.

One theory is that odd font sizes or heights cause this bug (somehow?) So turn any 15px fonts to 14 or 16, etc. I know you mentioned this in your question, but might want to check the WYSIWYG block settings too to check if there is something there that is odd.

Another is that the color comes from the color assigned to the body tag. So if you set the body background to the color of your problem area, although the 1px line will be there, it will now be hidden as it is the same color. This is different from what you stated as you did it at block level and this needs to be on the actual <body> tag.

Here is a decent article on resolving it.

Note there are some other mentions here on CSS and such type solutions, but I am assuming the issue is coming from one of the wrapping tables not your code.

If none of that works, then shift your blocks into "Code Snippets" as they do not get wrapped in anything so should remove the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.