I have created a new workflow rule for Case Comment object. When trying to retrieve from org browser getting this error

"Cannot read property 'split' of undefined"

and when i tried to retrieve via git command "sfdx force:source:retrieve -m CustomObject:Case_Comment__c" getting this message

=== Retrieved Source No results found

3 Answers 3


Unless you made a custom object called Case Comment, Case Comment is a standard object with the API Name CaseComment. So the command you're looking for is:

sfdx force:source:retrieve -m CustomObject:CaseComment
  • Yes i tried, but i couldnt get the workflows from the case comment, other fields and custom objects were retrieved. Any help on workflows? Commented May 20, 2021 at 7:59
  • Workflows are a different Metadata type, so you need Workflow:CaseComment. Here's a list of all supported Metadata types for reference. Commented May 20, 2021 at 13:03

Try to retrieve the source code by using the workbench, unzip the retrieved file into your local drive then launch: sfdx force:mdapi:convert --rootdir <c:\workbench\---> you can also try logging by using --loglevel LOGLEVEL Generally logs gets stored in $HOME/.sfdx/sfdx.log


This is what worked for me.

I created dummy workflow with the same name (CaseComment.Workflow-meta.xml) and retrieved source from org. It got updated with new values.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .