I'm trying to run the sfdx update command in Windows 10 and every time it gives me the following log:

PS C:\Windows\system32> sfdx update

sfdx-cli: Updating CLI... already on latest version: 7.94.3-a4e7c7955b

This is version released on April 1, and since then I have tried updating to latest release every week, and I could not get to the latest release, which I think now is 51.12.0 (May 13, 2021) - CLI 7.101.0

The CLI Repository says this is the latest version as well: https://github.com/forcedotcom/cli/blob/main/releasenotes/README.md

How can I update to latest release of SFDX CLI, can some one guide me?

  • 1
    Can you try sfdx update stable ? Thanks May 20, 2021 at 19:09
  • still same result sfdx-cli: Updating CLI... already on latest version: 7.94.3-a4e7c7955b
    – VarunC
    May 22, 2021 at 3:32
  • 1
    @Swetha - Thanks for having looked into it then and I found out recently that sfdx-dev-server plugin was the cause of this. I've added that as an answer to this question of mine.
    – VarunC
    Jun 3, 2021 at 12:40

2 Answers 2


So ultimately, I posted comment on a similar bug posted on GitHub CLI Repo - link - and got a resolution from there by another user suggesting to uninstall a plugin on my local machine.

Found out that it was due to sfdx-dev-server plugin. Had to uninstall the plugin and then ran sfdx update command to update my CLI to latest version and it ran successfully!


Did you install sfdx-cli with windows installer ? If yes, you can:

  • uninstall using windows uninstaller
  • run npm i sfdx-cli -g

And everytime you need an update, use npm i sfdx-cli -g to upgrade to the latest version

And to be sure to always have the latest version of sfdx-cli and useful plugins, you can add VsCode SFDX-Hardis extension to be notified when updates are available :)

Note: I am the main contributor of this open-source extension, and also CTO of Hardis Group Salesforce Team

enter image description here

  • That may be a great extension - I can't say because I haven't used it. But from my view, although some people will decipher it as such, a ':)' does not constitute an actual disclosure. From Help Center > Expected Behavior: "Post good, relevant answers, and if some (but not all) happen to be about your product or website, that’s okay. However, you must disclose your affiliation in your answers." Would you please edit your answer to add disclosure info?
    – Moonpie
    Jun 20, 2021 at 22:16
  • 2
    Answer edited :) Jun 21, 2021 at 4:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .