0

I have created a new field called as Abc__c

Have given all the required FLS for the field as well.

The field is visible in the classic view but not in the lightning view.

I have cleared Cache and have logged out and have logged in again as well multiple times but that didn't help either.

4
  • Is the page you are viewing this through a flexipage? If so, is it defined using the Record Details component or using Dynamic Forms? The former uses Page Layouts whilst the latter may not be using the page layout at all. (I am also assuming you are viewing classic and lightning through the same user with the same profile where FLS is defined.)
    – Phil W
    May 12 '21 at 7:02
  • Hey Thanks for prompt response. We are not using any flexipages here. And its the same user(Sys Admin) in my case May 12 '21 at 7:09
  • Did you try turning off page caching on the org (in Session Settings, scroll up and uncheck "Enable secure and persistent browser caching to improve performance" in the "Caching" section)? I know you mentioned clearing the cache though it isn't clear which cache you cleared.
    – Phil W
    May 12 '21 at 7:18
  • Thanks @PhilW... Will check it out... I have cleared cache in the browser but have not done in session settings May 12 '21 at 17:19
1

If the field is on Task/Event then you have to add those field to Global Action layout to view them in lightning.

Setup->>in quick find enter “Global action”->>click on New event->>edit layout->>drag and drop custom field->>save.

1
  • Thanks @Abhinav Thakur but its not the custom object not any standard object. May 12 '21 at 17:21
0

Did you try turning off page caching on the org (in Session Settings, scroll up and uncheck "Enable secure and persistent browser caching to improve performance" in the "Caching" section)? I know you mentioned clearing the cache though it isn't clear which cache you cleared. – Phil W May 12 '21 at 7:18

Posting Phil W's response as Answer because in 12 years of SFDC, I hadn't ever seen this occur but Phil W's solution resolved my issue. My FullSB change set was clean (fls, accessibility, profiles, etc. all there) and there was space on the page for the fields, they just weren't there in LEX. Cleared my browser cache but disable caching on session settings made the fields visible. When I re-enable it, the fields disappeared again. Disabled it is. Original poster never followed up, but this solution works for one use case of invisible fields. Fields occupy space but are visible in LEX

Fields Visible in Classic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.