I was using the "Retrieve source in manifest from org" command for the resources in package.xml file. However when I executed the command it failed saying "Starting SFDX: Retrieve Source from Org Cannot read property 'split' of undefined". There are no errors in the package file. I have authorized the org, reinstalled salesforce extension and the issue remains.

  • 1
    Is your sfdx up to date? You should run sfdx update to make sure it is.
    – Derek F
    May 11, 2021 at 14:13
  • Can you post your package file? May 11, 2021 at 14:36
  • @DerekF tried sfdx update and it did not fix it May 12, 2021 at 13:28
  • @NicholasSavini <?xml version="1.0" encoding="UTF-8"?> <Package xmlns="soap.sforce.com/2006/04/metadata"> <types> <members>Account.Business_Email__c</members> <name>CustomField</name> </types> <version>49.0</version> </Package> May 12, 2021 at 13:29
  • And what command are you running? It's helpful to add to edit you post and add it in there. May 12, 2021 at 14:09

1 Answer 1


Found the solution here : https://trailblazers.salesforce.com/answers?id=9064S000000kFosQAE

Karol Dylewski
Issue started with new Salesforce CLI Integration extension pack update.

As a solution, install previous version of this package

1. VScode -> Extensions (ctr shift x)
2. Find Salesforce CLI Integration
3. Click Uninstall dropdown, and then Install Another Version
4. I tried with 51.8.0 and now it works

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .