0

I'm trying to create an email template in lightning. The Related Entity Type dropdown is only loading Contact and lead, not all of the regular objects. image showing only contact and lead in dropdown

2
  • Try refreshing without Cache, that should do the trick. Commented May 10, 2021 at 19:18
  • I tried that but no change. I also tried a new browser and that didn't change anything either. Commented May 11, 2021 at 13:58

3 Answers 3

1

I had the same issue. My custom object was correct with Activities allowed and "Enhanced Email" setting was enabled. Remove cookies didn't fix. What finally worked was to disable Enhanced Email and enable it back. My custom object (and a full bunch of others) instantly appeared in the picklist. I was in a sandbox created after the Enhanced Email was activated in the production instance, but there was no Lightning template created yet.

0

I opened a case with Salesforce and the result was that "Enhanced Email" was disabled. This is the fix:

=============== Objects not available under "Related Entity Type" in Lightning email template https://help.salesforce.com/articleView?id=000349235&language=en_US&mode=1&type=1

However, before you enable this, please review the articles below about Enhanced Email.

Learn about the 'Enhanced Email' and EmailMessage objects https://help.salesforce.com/articleView?id=000313606&type=1&mode=1

Use Enhanced Email for More Email Functionality https://help.salesforce.com/articleView?id=sf.emailadmin_enhanced_email_overview.htm&type=5

To enable enhanced email, here are the steps.

  1. Click the gear icon on the upper right side, then click Setup
  2. On the quick find box on the left, type 'Enhanced Email'
  3. Click 'Enable'
0

My custom object was correct Activities allowed and Enhanced Email enabled. Remove the cookies didn't fix.

This worked for me. Disabled Enhanced Email, re-enable Enhanced Email

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .