4

I can't find any documentation to suggest this would be a limitation, but using my access_token from a usernamepassword flow I can access api endpoints but not a url like instance.salesforce.com/id. Thoughts?

My connected app has web, full etc for access level.

  • I ended up getting around this by using making a SOAP request for a session ID. I'm not going to close the question just yet, a oauth token would be better. – wellmstein May 2 '14 at 19:46
  • 2
    I believe you need to use the front door to use the session token. See frontdoor.jsp – sfdcfox May 2 '14 at 20:50
0

Check that profile of the user you are logging in with doesn't have "API only User" tickbox checked (located under "Administrative Permissions" section on profile page).

| improve this answer | |
  • Nope. The user is my user and a system administrator – wellmstein May 2 '14 at 11:07
0

Add the URL you are trying to access in remote sites. Remote sites can be accessed from Administration Setup - -> Security Controls -->Remote Site Setting

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.