10

As a System Administrator, I have a link on Contact pages to Log in as a Community User:

enter image description here

When most of my users log in, they have the "View Customer User" option, but not the login options. I would like to show this option for some of them -- but I can't figure out which permissions to assign to them. Which permission is it?

Note - the following permissions have not worked:

  • Manage External Users
  • Invite Customers To Chatter
  • Create and Manage Communities
  • Edit Self-Service Users
  • Manage Users
1
  • Hi Benj. In case you found a working solution by now, would you be wanting to share it as an answer? Nov 6, 2014 at 14:27

8 Answers 8

6

Per the docs, they need "Manage Users" and Read on Accounts.

2
  • I just tried this, too, and it doesn't seem to be working. Maybe a bug?
    – Benj
    Apr 30, 2014 at 14:26
  • Nice find BTW - I had searched the docs, but couldn't find that info the first time around.
    – Benj
    Apr 30, 2014 at 14:27
4

Although this question is already really old here is what I found out today by chance:

A user needs to have the Manage External Users permissions and must be included in a sharing group of the partner user's manager role.

If you navigate to a partner community user and click on the role, you see what role it reports to and in what sharing group the role is. I think per default this is "Role" & "Role, Role, Internal and Portal Subordinates". This means the user you'd like to have access to has to be in the reporting role or in a subordinate role of the reporting role

Example: Partner Role Info

As you can see, the partner role, reports to the role "Geschäftsführung" and is shared within "Geschäftsführung". Due to our role setup, which has "Kundenbetreuung" as a direct subordinate role to "Geschäftsführung", all users in "Kundenbetreuung" which have "Manage External Users" can access that functionality.

Roles Hierarchy

Sub roles of a direct subordinate role of the role a partner role reports to do not have access. I had to learn that the hard way ("child" role to "Kundenbetreuung" in my example).

3

Check who is the account owner and their Role Hierarchy. It might be higher than the user that is trying to login as the external user (contact under this account)

I spent a day looking at the same issue only to realize that it was due to the Role Hierarchy. Very few people pay attention to it when setting these things up. With all the permissions listed in the docs your users SHOULD be able to login as community users, unless, of course, the account owner's role is higher. Wish someone could save me a day of headache by pointing this out. The post states that MOST! not ALL users are unable to see this option. To me this screams "check your record-level permissions!" aka hierarchy.

3
  • 2
    I spent a day looking at the same issue only to realize that it was due to the Role Hierarchy. Very few people pay attention to it when setting these things up. With all the permissions listed in the docs your users SHOULD be able to login as community users, unless, of course, the account owner's role is higher. Wish someone could save me a day of headache by pointing this out. The post states that MOST! not ALL users are unable to see this option. To me this screams "check your record-level permissions!" aka hierarchy. Feb 5, 2016 at 0:33
  • @AlexKozlov maybe you can merge your comment into your answer so it's a little more clear?
    – metadaddy
    Feb 5, 2016 at 5:10
  • @AlexKozlov Placing someone above the account owner gives him account edit rights. So although it is a solution to the problem, I am not sure that is is necessarily a requirement : documentation just says you need edit access on the account (as well as other authorisations).
    – altius_rup
    Dec 6, 2017 at 17:13
2

Originally, I thought this was only available to System Administrators but I now think, after a little research, that the permission you're looking for is Edit Self-Service Users.

3
  • I could have sworn this was available a couple releases ago - do you know if there's been a change?
    – Benj
    Apr 29, 2014 at 21:23
  • I updated my original response, which was wrong.
    – greenstork
    Apr 29, 2014 at 21:24
  • Sadly that didn't work either...
    – Benj
    Apr 30, 2014 at 2:26
2

I use the 'Manage External Users' permission for this in combination with 'Edit' on Account and it works fine.

That's a lot safer than giving them 'Manage Users'.

So I guess that means the Docs are also wrong: https://help.salesforce.com/HTViewHelpDoc?id=networks_create_external_users.htm&language=en_US

1

I experienced this same issue after a change set deployment and the only fix I found was View All and Modify All on Accounts and Contacts for the profiles that needed the access.

0

Looks like "Login As Portal User" button is only available to users with profiles that have the "Edit Self-Service Users" permission and "Edit" access on the account.

0

Just in case someone is looking at this is 2021, another thing to also check is your record sharing in addition to your object level sharing. I had an issue with this because my org-wide defaults for Accounts were set to Public Read Only. Once I gave my users read/write access via a manual sharing rule on the Account, my issue was resolved. So I think overall, these are the items Admins should check when troubleshooting this:

  1. Role Access (making sure the internal user has a role, then checking that the assigned role reports to or is the same as to Partner Account's Owner User Role)
  2. Object Level Access to Account is set to Edit
  3. Record Level Access to Account is set to Edit
  4. Community Membership (internal user is a member of the community via permission set or profile access)
  5. Access to the Manage External Users App permission

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.