1

After configuring Opportunity Contact Role related list, Users can only choose contact they own although they have read access to other contacts.

I need them to be able to select any contacts.

What I checked: -Sharing settings on Contacts = Public Read/Write, -Sharing settings on Opportunity = Public Read/Write -Using Salesforce Professional Edition

Any ideas are most welcome. Tks

4
  • how about create a sharing rule to share the contacts – Bforce Apr 29 '14 at 18:46
  • @Baskaran Tried creating a sharing rule without success: Contact: owned by members of Entire Organization Share with Entire Organization Access : Read Write. I feel that the rule is somehow redundant since the sharing is already public read/write... – AlexandreJ Apr 29 '14 at 18:49
  • 1
    Correct. i agree with you Alexander. – Bforce Apr 29 '14 at 18:59
  • help.salesforce.com/… – AlexandreJ Apr 29 '14 at 19:09
1

This is the solution found with Salesforce Support:

The reason why you are unable to add this contact in opportunity contact roles is because the contact record doesn't have an Account Name associated to it. Please know that contacts that are not linked to an Account (personal contacts) are always private, regardless of your organization's sharing model. Only the owner of the contact, System Administrators, or users with View All for Contacts, or View All Data, can view it. However, users with View All or View All Data, but lacking Modify All for Contacts, or Modify All Data, cannot edit the Private Contact record.

Sharing rules do not apply to private contacts. If your organization uses divisions, private contacts always belong to the global division.

To make it visible in lookup search results, make sure you meet following conditions: -You are the owner of the contact. OR -Enhanced Lookups is enabled for Contact ( => Setup | Customize | Search | Search Settings)

For more information, you may visit the Help and Training article link below:

https://help.salesforce.com/apex/HTViewSolution?urlname=Private-contacts-do-not-show-in-lookup-search-results&language=en_US

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.