0

I'm trying to export a Lightning Community Template. My export is successful, and I'm able to generate a new community using my exported Template. But the new community generated from the template is missing

  • Navigation User Menu
  • Search
  • User Profile Menu

All these components I can see and use from the community where I exported my template from. And I could not find a way to turn any of these options in new community I generated from using my exported template.

Below is how different my Compact Header component is in both my communities:

[1.] => Compact Header component in Community where I Exported my Template from.

[2.] => Compact Header component in Community which I generated using the Exported Template.

Please help how I can include the missing components in my Community Template or enable them in new community?

enter image description here

My Community Theme Settings:

enter image description here

6
  • I tried this in my Dev org but could see the components that you said are missing in my org. Exported the template and created an Experience Builder site by selecting it in the Experience Creation wizard. Are you doing the same or are you Packaging the Experience Builder template for distribution? Thanks – Swetha Apr 10 at 16:05
  • Yes, ultimately, I want to package. But this is presently just done in same development org. I just configured my community and then used Export option to export as Community Template. Then within same org, I created a Test Community using the Template (I just exported) above. And the community created using the template was missing all these component options. I tried multiple times and same result. – VarunC Apr 10 at 21:23
  • 1
    @Swetha - I've updated question with my Community Theme Settings, may be these have different effects? – VarunC Apr 10 at 21:30
  • I've tried with the same Theme Settings but still can't reproduce the behavior you mentioned. I have used customerService Template. – Swetha Apr 11 at 8:01
  • I have created a new Dev org d5g000004jeofeai-dev-ed.my.salesforce.com/… and couldn't replicate the behavior here too. Feel free to login as needed and let me know your inputs. Thanks – Swetha Apr 14 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.