0

I have updated the standard NAME field's label on custom object through rename tabs and labels in Setup. But I am not able to retrieve the Name field label change.

Here is my package xml:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>Product_Tag__c.Name</members>
        <name>CustomField</name>
    </types>
    <types>
        <members>Product_Tag__c-en_US</members>
        <name>CustomObjectTranslation</name>
    </types>
    <version>50.0</version>
</Package>

Here is the output retrieved from Workbench:

<?xml version="1.0" encoding="UTF-8"?>
<CustomObjectTranslation xmlns="http://soap.sforce.com/2006/04/metadata">
    <caseValues>
        <plural>false</plural>
        <value>Product Tag</value>
    </caseValues>
    <caseValues>
        <plural>true</plural>
        <value>Product Tags</value>
    </caseValues>
    <startsWith>Consonant</startsWith>
</CustomObjectTranslation>

How can I retrieve the name field label change and deploy that.

0

I was able to replicate the issue and you would need to retrieve the object (Product_Tag__c) to update the standard field label. You should be able to see something like below in your object file which has label name.

<nameField>
    <label>Product Tag Name</label>
    <trackHistory>false</trackHistory>
    <type>Text</type>
</nameField>

Kindly review migration of standard fields limitation here.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.