0

I'm having picklist metadata problems with VS code and a regular sandbox (not a scratch org). I'm using source format with the sandbox. I have a picklist where some values have leading zeros, e.g. "01", "02", etc. When I retrieve the field's metadata, the leading zero has been dropped in both the label and full name. Example: instead of "01" I get "1":

<fullName>1</fullName>
<default>false</default>
<label>1</label>

I need to commit and deploy this metadata with the leading zero. This is a regular picklist, it doesn't use a Global Value Set.

I searched the SF extension github but didn't find any issues.

Has anyone run into this? I tried disabling the RedHat XML extension but it didn't solve anything.

UPDATE I tried a different computer that had earlier versions of VS Code and SF Extension Pack, and it worked correctly. Then I updated VS Code and SF Extensions to the latest version and it dropped the leading zeros also. I've opened an issue on the SF extensions github.

1

There's an issue with a new experimental Preference Setting in the SF Extension Pack for VS code. The fix is to disable this setting:

  1. File > Preferences > Settings (Windows or Linux) or Code > Preferences > Settings (Mac)
  2. Search for salesforcedx-vscode-core and uncheck Experimental: Deploy Retrieve

See this github issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.